Home Page for the TeradataForum

Archives of the TeradataForum

Message Posted: Mon, 11 Feb 2013 @ 14:50:43 GMT

  <Prev Next>   <<First <Prev

Subj:   Re: Error : 3704: "0A"X not a valid Teradata SQL
From:   Bakthavachalam, Roopalini

Thanks everyone for your inputs !! Really appreciate it and apologies for not responding if the query worked after removing the single quotes.

Sughesh ,Mike and Barb - You are absolutely correct. 'Single quote' is the culprit here. I didn't copy the SQL from word. I copied the SQL from "SHOW VIEW " command from SQLA itself. There were lot of /*comments*/ in the SQL, and one of them had a single quote and that was causing the error. Once I removed that , the query ran fine in SQLA.

Mike - My SQLA version is (not SQLA or higher). You mentioned that the '0A'x characters get removed from the CREATE/REPLACE statements and that's the reason, I believe , why the REPLACE VIEW statement worked while creating the VIEW.

Thanks again for all the inputs!!



  <Prev Next>   <<First <Prev
  Top Home Privacy Feedback  
Copyright for the TeradataForum (TDATA-L), Manta BlueSky    
Copyright 2016 - All Rights Reserved    
Last Modified: 24 Jul 2020