Home Page for the TeradataForum

Archives of the TeradataForum

Message Posted: Thu, 28 Mar 2013 @ 14:14:32 GMT

  <Prev Next>  
Next> Last>>  

Subj:   7451 Invalid Timestamp Error
From:   Paul, Aashish


I have a table with 6 timestamp fields in it. While trying to retrieve 4 of these timestamp fields I am getting an error "SELECT Failed. [7451] Invalid timestamp."

This happens only for some of the records and not all records in these fields.


     Select TS2,TS3,T4,TS6
     from table1                  - Failed


     SELECT TS2,TS3,T4,TS6
     from table1
     where field 11 = 'XYZ'       --  works

I have tried casting the timestamp as a CHAR with no luck. If I try to CAST as Time the SQL works, but if I try to CAST as DATE the SQL fails.

I tried creating a dummy table to then ALTER the timestamp fields to a CHAR(26) field, but this also failed with error code 3558 . I guess this is not a permitted.

Any suggestions on how to correct the issue are welcome.



  <Prev Next>  
Next> Last>>  
  Top Home Privacy Feedback  
Copyright for the TeradataForum (TDATA-L), Manta BlueSky    
Copyright 2016 - All Rights Reserved    
Last Modified: 15 Jun 2023