Home Page for the TeradataForum

Archives of the TeradataForum

Message Posted: Wed, 25 Jan 2006 @ 11:04:44 GMT

  <Prev Next>  
Next> Last>>  

Subj:   Wrong datatype conversion using oledb provider
From:   Anomy.Anom


i try to set up a sql analysis server 2005 cube based on a teradata data source. i first used teradata oledb provider and later on tried it also with version 1.4 without success. our teradata release is V2R. Version

i have the problem that my decimal(18,5) and decimal(18,3) teradata datatypes obviously cannot be represented correctly in sql analysis server 2005. when using a table with these datatypes data exploration is not possible. i receive the following error message in sql server 2005 "The data value could not be converted for reasons other than sign mismatch or data overflow. For example, the data was corrupted in the data store but the row was still retrievable.#" nevertheless the cube can be loaded - but the values are wrong (eg. the value 234234.12345 will appear as 23423412345.00). integers and decimal(18,0) are represented correctly.

conversion of the attributes in question to integers also worked fine - but it's not the preferred solution as i need full precision.

has anyone an idea how to solve this?

is there a setting in the data link properties of the ole db provider which can lead to a correct datatype conversion?

thanks in advance for any hint!



  <Prev Next>  
Next> Last>>  
  Top Home Privacy Feedback  
Copyright for the TeradataForum (TDATA-L), Manta BlueSky    
Copyright 2016 - All Rights Reserved    
Last Modified: 28 Jun 2020