Home Page for the TeradataForum

Archives of the TeradataForum

Message Posted: Mon, 31 Jan 2011 @ 08:19:22 GMT

  <Prev Next>  
Next> Last>>  

Subj:   5547 error compiling Stored Procedure
From:   DWellman

Hi folks,

I'm trying to compile a Stored Procedure but this is failing with "Error 5547 Internal Error: Can not find mt.exe."

The stored procedure is ok because I can compile it on a different TD system.

So it looks to be the environment that my TD system is running in.

System#1 - where the compile fails

This is the Teradata 13.0 Express ( running on Windows XP (SP3). My C compiler is Visual Studio 2008 (VC9.0). I also have some other versions of the C compiler (VC 2003 etc) but that is the highest version and seems to be what TD is looking for by default.

Cufconfig shows the CompilerPath set to my vc "\bin" folder containing cl.exe and the LinkerPath references link.exe in the same folder.

I tried changing CompilerPath and LinkerPath to reference the VC 2003 folder but that didn't make any difference. Interestingly (or not !) the initial values for these parameters on my system included the full path and program name. However, when I tried to change them to reference my VC 2003 software every TD restart would over-write what I'd set back to the VC 9.0 (VS 2008) folders. Eventually I got my changes to 'take' by NOT including the module names in the parameter values.

System#2 - where the compile works

This is also the Teradata 13.0 Express ( but running on Windows Server 2003. My C compiler is VC 2003. This worked 'out of the box'.

Any ideas why this is not working on my Win XP system ?



Ward Analytics Ltd: Information in motion (www.ward-analytics.com)

  <Prev Next>  
Next> Last>>  
  Top Home Privacy Feedback  
Copyright for the TeradataForum (TDATA-L), Manta BlueSky    
Copyright 2016 - All Rights Reserved    
Last Modified: 15 Jun 2023