Home Page for the TeradataForum

Archives of the TeradataForum

Message Posted: Mon, 14 Apr 2003 @ 20:05:37 GMT

  <Prev Next>  
Next> Last>>  

Subj:   Teradata/Demo on XP
From:   David Wellman


I tried to install the v2r4.1 demo/cd on Win/XP today and failed (miserably !). I've installed this previously on one PC but need it on a second one.

As per the "Files4xp" instructions, I created a new install directory on the PC, copied the contents of directory TNT41 to it and then overwrote the "setup.ins" file.

I ran the setup.exe and got through the installation of the DBMS itself. At the end of this I said "No" to viewing the readme file and "No" to restarting the PC. When I clicked on "Finish" the install process died. The dialog box disappeared, task manager showed there were no applications running.

Just for the heck of it, I then copied file "pdelib.dll" into the appropriate directory as well (but things had gone wrong before this point).

I re-booted and got the message shown in the "Files4xp.doc" as shown below;

Teradata GTW Reserve Port Event: Bind error: 10048
Gtwrsrvtdmst must start immediately after TCP/IP initialization

Rebooting should resolve the problem.

So I ran the .REG file to update the registry, rebooted and the message goes away.

I tried to re-run the install but get messages saying that TDAT demo is already installed, you must un-install first. I couldn't get back to the install process to add in Queryman and the utilities etc etc.

I even tried un-installing (which was successful) and re-installing but got back to the same error.

I can manually start the Teradata RDBMS initiator service from "services", but I can't get connected to the DBMS using DBW. If I look in the Event Viewer I can see all of the normal starting messages, including "The configuration is operational", but there is the following message which doesn't look healthy.

29002: PDE warning cnscim: cnsinetd_getfd unable to get socket fd '208' error 6. No such device or address. The handle is invalid.

I think this message is as a result of me trying to connect using DBW.

(Is this a windows socket initialisation error 6?) I have checked that we can ping "localhost" and other pc's on the network and they work ok, so it looks like tcp/ip is installed correctly.

I am told that the Windows userid used to run the install is an administrator, and certainly we didn't get any "you must be an administrator" messages during the install process.

The only thing that's different on this PC to others I've installed on is that we're installing on the D drive and not the C drive, but that can't make a difference (can it?).

All ideas gratefully appreciated.



  <Prev Next>  
Next> Last>>  
  Top Home Privacy Feedback  
Copyright for the TeradataForum (TDATA-L), Manta BlueSky    
Copyright 2016 - All Rights Reserved    
Last Modified: 15 Jun 2023