Home Page for the TeradataForum
 

Archives of the TeradataForum

Message Posted: Mon, 30 Mar 2009 @ 18:08:27 GMT


     
  <Prev Next>   <<First <Prev Next> Last>>  


Subj:   Re: Deleting on an identity column
 
From:   Anomy Anom

<-- Anonymously Posted: Mon, 30 Mar 2009 12:56 -->

Glenn,

Yes, that is exactly what was happening. Although the issue has been resolved.

The problem appears to have come from a Java natural optimization that was happening.

If anyone is curious about the problem, I cannot quite figure out why it reacted the way that it did, but it had to do with not explicity setting the id column's value to be null while creating a prepared statement.

So even though an id was being generated, it was still not capable of being retrieved.

For example for your example, before the deletion, if I ran the following query

     Select * from gmc_id_test
     where i1 = 1;

It would return 0 rows, but if one ran

     Select * from gmc_id_test
     where i1 between 0 and 2, would return the row;

Thanks for looking at the problem though.



     
  <Prev Next>   <<First <Prev Next> Last>>  
 
 
 
 
 
 
 
 
  
  Top Home Privacy Feedback  
 
 
Copyright for the TeradataForum (TDATA-L), Manta BlueSky    
Copyright 2016 - All Rights Reserved    
Last Modified: 27 Dec 2016